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Accurate simulation of lava flow extent is essential information for scientists or stakeholders 

confronted with imminent or long-term lava flow hazard from basaltic volcanoes. Knowing what can 

be the area inundated by a potential or imminent lava flow can improve their understanding of the 

spatial distribution of lava flow hazard, influence their land use decisions and support evacuation 

planning during a volcanic crisis (Damiani et al., 2006; Herault et al., 2009; McGuire et al., 2009; Morgan 

et al., 2013). 

Q-LavHA (Quantum-Lava Hazard Assessment) (Mossoux et al., submitted) is a freeware plugin which 

simulates channelized ʻaʻā lava flow inundation probability from one or regularly distributed eruptive 

vents on a Digital Elevation Model (DEM). It combines existing probabilistic and deterministic models 

(Felpeto et al., 2001; Harris and Rowland, 2001) and proposes some improvements to calculate the 

probability of lava flow spatial propagation and terminal length.  

 s s s
- Install QGIS (https://www.qgis.org/en/site/forusers/download.html). The minimum required 

version of QGIS is 2.14. 

- Copy the folder ‘volcano_plugin’ to the QGIS plugins directory. This directory is usually located at 

the following places: 

WINDOWS:  ~ \Users\<UserName>\.qgis2\python\plugins 

MAC:  ~ /Users/<username>/.qgis2/python/plugins 

LINUX:  ~ /home/<username>/.qgis2/python/plugin 

If the python/plugins folders don’t exist create them and copy the volcano_plugin to that folder.  

- Restart QGIS and activate the plugin: Plugins>Manage and install plugins>All>check Q-LavHA. 

 

The DEM is a .asc or .tiff file that has to be projected in UTM. To avoid simulations to be stuck in 

abnormal depressions, it is recommended to fill the sinks during a pre-processing manipulation. 

REPROJECTION: 

Q-LavHA is working with DEMs projected in UTM. To reproject a DEM that has a geographic coordinate 

system (lat/lon) to a UTM projected coordinate system (m): QGIS>Raster>Projections>Wrap 

(Reproject):  

- Input: the DEM with a geographic coordinate system (lat/lon). 

- Output: name of the new DEM. 

- Source SRS: select>in the second panel select under Geographic Coordinate System WGS 84. 

- Target SRS: select>in the second panel select under Projected Coordinate System the adapted 

WGS84/UTM zone of your study area (Fig. 1).  

https://www.qgis.org/en/site/forusers/download.html
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- Verify that QGIS wrote: gdalwarp -s_srs EPSG:4326 -t_srs EPSG:32735 -of GTiff "inputDEM" 

"outputDEM.tif". 

- If not, edit the command and make the needed changes.  

 

Figure 1 - UTM zone map for the world 

FILL SINK: 

Fill in abnormal depressions present in the DEM is important to avoid the simulation to be stuck due 

to errors present in the DEM. QGIS>Raster>Analysis>Fill nodata: 

- Input: the DEM.  

- Output: name of the new DEM. 

 

In order to assess the accuracy of the simulated channelized ʻaʻā lava flow, a fitness index (FI) can be 

calculated. Following Favalli et al (2009), the simulated lava flow can be compared to a real lava flow. 

The real lava flow has to be a .asc or .tiff file where a ‘1’ value is assigned to all pixels corresponding 

to the real lava flow. The resolution of the real lava flow has to be the same as the DEM resolution. 

- CREATE THE REAL LAVA FLOW by creating a new shapefile: click on the new shapefile layer icon.  

 Type: polygon. 

 Specify CRS: WGS84/UTM zone of the study area. 

 New attribute: name=value/ type=whole number>add to attributes list. 

 Ok. 

 Save the shapefile to your working folder. 

 

- DRAW THE REAL LAVA FLOW: Start editing the layer:  

 Select the layer you want to edit. 
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 Edit the layer by clicking on the ‘toggle editing’ button. 

 Click on the ‘add features’ button and draw the polygon. 

o Backspace to erase a vertex.  

o Right-click to end the drawing.  

o ID= 1 and value= 1. 

 Click on the ‘save layer edits’ button. 

 Stop editing mode by clicking again on the ‘toggle editing’ button. 

Toggle editing Add features Save layer edits New column 

  

 

 

 

- CONVERT the shapefile to a raster 

 Open the attribute table: select the layer>right-click>open attribute table. 

 Verify that there is a field value=1. If not:  

o Start the editing mode of the attribute table by clicking on the ‘toggle editing 

mode’ button. 

o Add a column ‘Value’ to the attribute table: click on the ‘new column’ button. 

 Name: value. 

 Comment: / 

 Type: whole number (integer). 

 Width: 1. 

o Type ‘1’ in the new field. 

o Click on the ‘save layer edits’ button. 

o Stop editing mode by clicking again on the ‘toggle editing’ button. 

 Cut the region of the real lava flow from the DEM: Raster>Extraction>Clipper: 

o Input: DEM file. 

o Output: extent real lava flow (.tif). 

o No data value: the NoData value of the DEM that you are using. To know what is 

that value: open the DEM layer properties>transparency>No data value. 

o Clipping mode: extent.  

 Convert the value of the raster to zero: Raster>Raster calculator: 

o Raster calculator expression = extent of the real lava flow * 0. 

o Output layer: zero value raster.tif. 

o Current layer extent. 

o Output format: Geotiff. 

 Convert the shapefile to a raster by using the zero value raster: 

Raster>Conversion>Rasterize:  

o Input file: shapefile of the real lava flow. 

o Attribute file: the column ‘value’ in the attribute table. 

o Output file for rasterized vectors>select: the zero value raster. 

o Output file: name of the output file (.tif). 
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4 ss
Q-LavHA can be accessed using QGIS. If well installed, the plugin can be open through the tool 

bar Q-LavHA icon.  

 s
When Q-LavHA is launched, the main window appears. It is composed of three tabs (Fig. 2).  

The first tab allows entering the DEM for the analysis, the option of calculating fitness indices based 

on a real lava flow raster, and where the output has to be saved. Both DEM and real lava flow are 

automatically converted to the .asc format required by Q-LavHA. The user can save the parameters 

used during the simulation or import previous ones. 

In the second tab, the user defines the vent location. The starting coordinates can be inserted manually 

or information can be extracted from an already existing shapefile. If the probability density function 

(PDF) map option is chosen, the user selects the probability density function map and introduces the 

minimum susceptibility value for the simulation. For linear fissure, surface area and PDF map, a 

distance between the vents has to be defined.  

The third tab contains all the lava flow parameters related to the propagation, the length constraints, 

the number of iterations, and the threshold used for producing the lava flow probability map. Only 

pixels with probabilities higher than the user defined threshold are shown on the map.  

The output produced by Q-LavHA expressing the probability of a pixel to be flood by lava. It is 

presented in an .asc raster format and is added as a new layer to the active QGIS project. A summary 

file is simultaneously produced to recall the parameters used during the simulation. 

s - inputs parameters 

- Define the DEM on which you want to work. Pay attention, the file will be automatically 

transformed into an ascii file if a .tiff is uploaded.  To choose a .tiff file, change the file type in the 

window that pops up.  

- Define the REAL LAVA FLOW if you want to calculate a fitness index (Tarquini and Favalli, 2011). 

Pay attention, the file will be automatically transformed into an ascii file if a .tiff is uploaded. To 

choose a .tiff file, change the file type in the window that pops up.  

- Define the OUTPUT path and name. 

- If you want to use previous or SAVE THE INPUT PARAMETERS that will be used during the 

simulation, the user can import or export the input parameters as a .csv file. 
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Figure 2- Q-LavHA interfaces. 
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s - vent location 

MANUALLY 

- The starting coordinates can be inserted manually. Base on the type of vent that has to be 

simulated, add the UTM coordinates manually. For a POINT, select Point and fill in coord 1. For a 

LINEAR FISSURE, select linear fissure and fill in coord 1 to 2. For a SURFACE AREA, select surface 

area and fill in coord 1 to 4. For polygons, the code automatically recalculates the extent of the 

source zone to the largest-fit rectangle. 

- If you don’t know the coordinates of the vent: before opening Q-LavHA, use the plugin 

COORDINATE CAPTURE>Start capture>point on the DEM to the desired location. The tool 

shows coordinates which remain displayed, even after moving the cursor.  

FROM AN EXISTING SHAPEFILE 

- The starting coordinates can be extracted from an already existing shapefile. Select the option 

CHOOSE LAYER and choose the desired vector layer (point, line or polygon UTM projected) from 

the LIST of the layers opened in the working space or BROWSE through your directory to find the 

desired layer. This layer will automatically open in the working space. The coordinates of the first 

feature of that layer will be extracted.  

PDF MAP 

- A probability density function map (PDF MAP) can be introduced and used to make simulations on 

a large area. A PDF map attributes a probability of vent opening to every pixel within the 

considered area (Bartolini et al., 2013). A PDF map can be produced with QVAST (Bartolini et al., 

2013). Based on a specific threshold (MINIMUM PDF VALUE TO SIMULATE), the code analyzes 

successive pixels till encountering a pixel with a value higher or equal to the threshold and starts 

simulations. This minimum PDF value enables to avoid simulating lava for pixels with no or 

negligible chance to host an eruption site. ‘No Data’ pixels are ignored. Result of each individual 

simulation is weighted by the PDF value of the source pixel. 

If the use PDF Map option is chosen, the user selects the probability density function map (.asc or 

.tiff file) and introduces the minimum PDF value for the simulation. Pay attention, the PDF file will 

be automatically transformed into an ascii file if a .tiff is uploaded. To choose a .tiff file, change the 

file type in the window that pops up.  

 

 

- For linear fissure, surface area and PDF map, simulations are not realized at each pixel. The user 

can define, in the DISTANCE BETWEEN THE VENTS (m) box, the spacing between successive 

punctual simulations.  
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 - lava flow simulation propagation 

PROPAGATION 

Corrective factors are included enabling the lava to overcome small topographical obstacles or pits.  

- 𝐇𝐜 factor is always added to the elevation. This enable to simulate the lava thickness (Felpeto et 

al., 2001). It is a float number (m). 

- 𝐇𝐩 is also a topographical corrective factor that is only used when Hc is not enough. It replaces 

Hc (float number) (m). If both Hc and Hp are used, the Hp value needs to be larger than Hc to be 

effective.  

- 𝐇𝟏𝟔: If the lava flow line reaches a pit, which is too deep to be overcome by the corrective factors 

Hc and Hp, Q-LavHA includes the option to consider the 16 next surrounding pixels (H16). If lava 

flow line can propagates to one the 16 surrounding pixels, it continues its path. If not, the 

simulation stops. It is recommended to activate the option. 

- PROBABILITY TO THE SQUARE: this option narrows results spatially because the chance to take 

the steepest slope is increased. The second power induces that the pixel with the highest elevation 

differences gets a higher probability. Therefore, the flow line is more likely to follow the steepest 

slope path. It is recommended to use it.  

More information about these factors can be found in Mossoux et al. (2016). 

LAVA FLOW LENGTH CONSTRAINTS 

- MAXIMUM LENGTH: define a maximum length (m) till where the lava can flow. This distance can 

be easily estimated by studying the maximum length reached by historical lava flows of the studied 

volcano. Q-LavHA consider the maximum length as the traveled distance by the lava flow line and 

not the crow distance. 

- DECREASING PROBABILITY: Because the length of each lava flow is not constant for a given 

volcano, it can be assumed that the probability of reaching a certain length can be expressed by a 

decreasing cumulative density function following a normal distribution (𝜑) (Bonne et al., 2008). 

This second option allows weighting the probability of lava inundation of each pixel along a lava 

flow line based on a decreasing cumulative density function. To use this equation, the user has to 

define the average length and the standard deviation of the historical lava flows of the volcano. 

The final probability expressed by each pixel is a result of a calibration of the pixels with a 

decreasing cumulative distribution function. 

- FLOWGO is a cooling-limited model. It is recommended to use this model only if the constraints of 

the lava flows physic-rheological properties are well constraint. The predefined advanced 

parameters are from Harris & Rowland (2001) on Etna flows. The key parameters are effusion rate, 

lava initial viscosity, phenocryst content and channel ratio. The lava flow stops when at least one 

of the following conditions holds: (1) its velocity is zero, (2) the lava core temperature reaches the 

solidus or (3) the yield strength at the base of the channel is greater than the downhill stress. 

If Q-LavHA reaches an area surrounded by more or equal to four NoData pixels (a lake or a sea), 

simulations stops. 

More information about these options can be found in Mossoux et al. (2016). 
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SIMULATION 

- NUMBER OF ITERATIONS: the number of lava flow lines computed from one vent. A minimum of 

1500 iterations is recommended to obtain stable results. 

- THRESHOLD: the minimum probability considered in the simulation result (%). Only pixels with 

probabilities higher than the user defined threshold are displayed on the map. 

s s

- Use the RUN button to start the lava flow simulation. 

- Use the CANCEL button to stop the simulation. 

- If you want to refresh all the tabs, click on the RESET ALL button.  

 

When the simulation is done, QGIS displays automatically the result expressing the probability of a 

pixel to be flood by lava.  

- In the output folder tree files have been produced:  

 The simulated lava flow (.asc) (Fig. 3) 

 The projection information of the lava flow (.prj) 

 ‘…_summary’ = summary of parameters used during the simulation (.asc) 

 

- To adapt the display of the lava flow: 

 Layer properties>Style>Render type>Singleband pseudocolor>Load min/max values>choose a 

color>Classify>Ok 

 

Figure 3 - Example of a simulation realized for the 2001 Etna lava flow (Mossoux et al. 2016) 
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The probabilistic lava flow map produced by Q-LavHA should be interpreted with care. Q-LavHA is a 

plugin which attempts to approach the reality of a channelized ʻaʻā lava flow inundation as accurately 

as possible. However, the outcome of the simulation depends on the quality of the DEM used and the 

selected simulation parameters. The probability of being inundated has to be interpreted as having a 

higher or a lower chance to be inundated. We consequently recommend the users to interpret the 

results as the sum of the trajectories a flow can potentially follow if an eruption occurs. 

 

- SRTM90m : srtm.csi.cgiar.org/SELECTION/inputCoord.asp 

  

http://srtm.csi.cgiar.org/SELECTION/inputCoord.asp
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